Montag, 16. März 2015

BFD for Static Routing

Вся информация взята с cisco.com, публикую чтобы не забыть.
SWG
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/1
 port-type nni
 no switchport
 ip address 1.1.1.0 255.255.255.254
 bfd interval 100 min_rx 100 multiplier 3

interface FastEthernet0/24
 no switchport
 ip address 2.2.2.0 255.255.255.254

ip route static bfd FastEthernet0/1 1.1.1.1
ip route 10.10.10.2 255.255.255.255 2.2.2.1
ip route 10.10.10.2 255.255.255.255 FastEthernet0/1 1.1.1.1


Router
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface GigabitEthernet0/1
 ip address 1.1.1.1 255.255.255.254
 duplex auto
 speed auto
 bfd interval 100 min_rx 100 multiplier 3
!
interface GigabitEthernet0/2
 ip address 2.2.2.1 255.255.255.254
 duplex auto
 speed auto
!
ip route static bfd GigabitEthernet0/1 1.1.1.0
ip route 10.10.10.1 255.255.255.255 2.2.2.0
ip route 10.10.10.1 255.255.255.255 GigabitEthernet0/1 1.1.1.0

Можно BFD привязать к int Vlan и к подъинтерфейсу маршрутизатора (802.1q)

DETAILED STEPS
    Command or ActionPurpose
    Step 1enable 


    Example:
    Device> enable
    Enables privileged EXEC mode.
    •  Enter your password if prompted.

    Step 2configure terminal 


    Example:
    Device# configure terminal
    Enters global configuration mode.  
    Step 3interface type number


    Example:
    Device(config)# interface serial 2/0
    Configures an interface and enters interface configuration mode.  
    Step 4ip address ip-address mask 


    Example:
    Device(config-if)# ip address 10.201.201.1 255.255.255.0
    Configures an IP address for the interface.  
    Step 5bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier


    Example:
    Device(config-if)# bfd interval 500 min_rx 500 multiplier 5
    Enables BFD on the interface.  
    Step 6exit 


    Example:
    Device(config-if)# exit
    Exits interface configuration mode and returns to global configuration mode.  
    Step 7ip route static bfd interface-type interface-number ip-address [group group-name [passive]]


    Example:
    Device(config)# ip route static bfd serial 2/0 10.1.1.1 group group1 passive 
    Specifies a static route BFD neighbor.
    •  Theinterface-type,interface-number, and ip-addressarguments are required because BFD support exists only for directly connected neighbors.

    Step 8ip route [vrf vrf-nameprefix mask {ip-address | interface-type interface-number [ip-address]} [dhcp] [distance] [name next-hop-name] [permanent | track number] [tag tag]


    Example:
    Device(config)# ip route 10.0.0.0 255.0.0.0 
    Specifies a static route BFD neighbor.  
    Step 9exit 


    Example:
    Device(config)# exit
    Exits global configuration mode and returns to privileged EXEC mode.  
    Step 10show ip static route 


    Example:
    Device# show ip static route
    (Optional) Displays static route database information.  
    Step 11show ip static route bfd 


    Example:
    Device# show ip static route bfd 
    (Optional) Displays information about the static BFD configuration from the configured BFD groups and nongroup entries.  

    Keine Kommentare:

    Kommentar veröffentlichen